Upgrade Groovy and Spock to maintained versions

Description

Groovy 2.1 and Spock 0.7 are very old and unmaintained. Upgrading to maintained, stable versions provides obvious benefits. Versions 2.3.x and 1.0 respectively are maintained and widely supported by IDE plugins.

Environment

N/A

Reporter

Mark Chesney

Fix versions

Affects versions

Priority

Major
Configure