[JAVA API] - Cannot find LockService for mysql/h2/db-type

Description

So I'm trying to run Liquibase before Hibernate creates its sessionFactory that all by standard procedure, im not using Spring or anything of the like. This acts as a completely standalone java application. Hibernate works fine, but whenever I run liquibase.update() before creating my sessionfactory we get the following error:
https://pastebin.com/Jqv2iLJs
Please note also after creating my sessionfactory I recieve the SAME error,
I can confirm the error is happening on the liquibase.update() method!
It includes DEBUG Logging since I haven't been able to hook Liquibase into the Log4j2 to disable it, maybe it helps you.
As of now, I have found no workaround and no stack-overflow questions related to this topic.
If this is something so obvious I'm quite sorry for wasting your time, but im 16 and im a developer for Minecraft plugins so.... yeah, been doing java for like 2 years now and it this is my first time going into the whole ORM and Schema Generation stuffs

// EDIT

Code is following the liquibase documentation for java api: http://www.liquibase.org/2015/07/executing-liquibase.html

Realized it downloads the changelogs so i posted them to pastebin, sorry.
https://pastebin.com/CLTVqupX (master)
https://pastebin.com/66XsXMcC (1.0)

Environment

Windows 10
Java 8 (Latest build as of post - 171)
Running Hibernate 5.3.1.

Status

Assignee

Unassigned

Reporter

Articdive

Labels

None

Components

Affects versions

Priority

Major
Configure