Error when using dropAll and update twice in different schema

Description

Hi,

As a developer, I really often use the following command line to reset my database and replay all changes

Unfortunately, we choose to move our application table in a specific schema `FOO` for this example.

In our only changelog file, we have this:

My maven parameters are the following:

If I run the command `mvn clean liquibase:dropAll liquibase:update` on clear database, all is OK. But If after that I run `mvn clean liquibase:dropAll`, the execution ends in success but table `FOO.BAR` still exists πŸ˜“

If I put the value `<defaultSchemaName>foo</defaultSchemaName>` in the maven config and run on a clean (real empty) database the command `mvn clean liquibase:dropAll liquibase:update`, it ends with success. But if I run this same command another time, without any modification, it ends in failure.

So I seem to be block by liquibase 😒in any case due to this schema change.

Environment

Postgresql 9.6 (run from docker with command `docker run -it --rm -e POSTGRES_PASSWORD=test-password -e POSTGRES_USER=proxyuser -e POSTGRES_DB=postgres -p 5432:5432 postgres:9.6.10-alpine`
For the other part, it's used from maven:

Reporter

Kevin Davin

Affects versions

Priority

Critical
Configure