Uploaded image for project: 'Liquibase Core'
  1. CORE-3409

dropFirst fails if postgis installed in DB

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects versions: 3.6.2
    • Fix versions: None
    • Components: Database Support
    • Environment:

      liquibase.integration.ant
      PostgreSQL 9.5.13 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-16), 64-bit
      postgis: 9.6-2.4

    • Sprint:

      Description

      Trying to use dropFirst=true on liquibase:updateDatabase fails if postgis is installed as it tries to drop the public views

      Unable to update database. liquibase.exception.DatabaseException: liquibase.command.CommandExecutionException: liquibase.exception.DatabaseException: ERROR: must be owner of relation geography_columns [Failed SQL: DROP VIEW "public"."geography_columns"]
      

        Attachments

          Activity

            People

            • Reporter:
              psilosly Greg St.Onge
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: