Uploaded image for project: 'Liquibase Core'
  1. CORE-3412

Using Command line start option of java -jar <path-to-liquibase-jar>) dosent work in 3.5.5 version

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects versions: 3.5.5, 3.6.0, 3.6.1, 3.6.2, 3.6.3
    • Fix versions: None
    • Components: Command Line
    • Environment:
    • Sprint:

      Description

      The command line option of running liquibase like below
      java -jar <path-to-liquibase-jar>
      does not load all the extension class.

      However in the same setup if we use liquibase class programmatically it loads all the extension classes correctly. Also if we run liquibase using the liquibase executable file it works fine as this is using
      java -cp "$CP" $JAVA_OPTS liquibase.integration.commandline.Main
      which is in turn loading liquibase programmatically.

      So only option of using the jar directly using java -jar is not working.

      It appears that this was working well in 3.4.2 version and once we used 3.5.5 version this way of running fails.

      we checked the java verbose option to see if the classes are loaded into JVM ,
      we notice that the extension classes are loaded in 3.4.2 version and not in 3.5.5 version.

      We tried to check if this issue has been resolved in any further versions and we have tried till 3.6.2 and it dosent seem to work.

      In our case we have the following classes
      1. Database class
      2. Few Datatype classes
      3. few generators

      We notice only the database classes gets loaded and all other classes are ignored.

        Attachments

          Activity

            People

            • Reporter:
              raghavendra.mk Raghavendra
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: